# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^VIR\s+RECU\s+(\d+)\nDE:\s+([\s\S]*?)(\nMOTIF:\s+(.*))?$//g;t' <<< "VIR RECU 998721687978
DE: Mrs PAUL SMITH
564"