const regex = /^VIR\s+RECU\s+(\d+)\nDE:\s+([\s\S]*?)(\nMOTIF:\s+(.*))?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^VIR\\s+RECU\\s+(\\d+)\\nDE:\\s+([\\s\\S]*?)(\\nMOTIF:\\s+(.*))?$', 'g')
const str = `VIR RECU 998721687978
DE: Mrs PAUL SMITH
564`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);