use strict;
my $str = 'VIR RECU 998721687978
DE: Mrs PAUL SMITH
564';
my $regex = qr/^VIR\s+RECU\s+(\d+)\nDE:\s+([\s\S]*?)(\nMOTIF:\s+(.*))?$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";