import re
regex = re.compile(r"^VIR\s+RECU\s+(\d+)\nDE:\s+([\s\S]*?)(\nMOTIF:\s+(.*))?$")
test_str = ("VIR RECU 998721687978\n"
"DE: Mrs PAUL SMITH\n"
"564")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)