re = /^VIR\s+RECU\s+(\d+)\nDE:\s+([\s\S]*?)(\nMOTIF:\s+(.*))?$/
str = 'VIR RECU 998721687978
DE: Mrs PAUL SMITH
564'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result