$re = '/^VIR\s+RECU\s+(\d+)\nDE:\s+([\s\S]*?)(\nMOTIF:\s+(.*))?$/';
$str = 'VIR RECU 998721687978
DE: Mrs PAUL SMITH
564';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;