package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)house\s+(\d+[-\s]?[a-zA-Z]?)\b`)
var str = `FLOWERS 527 OFFICE 1217 HOUSE 1
ONE WAY 614 HOUSE 4-C
OTHER WAY 371 DEPARTMENT 209 HOUSE 25 C
SAINT GEORGE 378 DEPARTMENT 808 HOUSE 3 C BLA BLA BLA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}