import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)house\\s+(\\d+[-\\s]?[a-zA-Z]?)\\b";
final String string = "FLOWERS 527 OFFICE 1217 HOUSE 1\n"
+ "ONE WAY 614 HOUSE 4-C\n"
+ "OTHER WAY 371 DEPARTMENT 209 HOUSE 25 C\n"
+ "SAINT GEORGE 378 DEPARTMENT 808 HOUSE 3 C BLA BLA BLA";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}