// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)house\s+(\d+[-\s]?[a-zA-Z]?)\b").unwrap();
let string = "FLOWERS 527 OFFICE 1217 HOUSE 1
ONE WAY 614 HOUSE 4-C
OTHER WAY 371 DEPARTMENT 209 HOUSE 25 C
SAINT GEORGE 378 DEPARTMENT 808 HOUSE 3 C BLA BLA BLA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}