$re = '/(?i)house\s+(\d+[-\s]?[a-zA-Z]?)\b/';
$str = 'FLOWERS 527 OFFICE 1217 HOUSE 1
ONE WAY 614 HOUSE 4-C
OTHER WAY 371 DEPARTMENT 209 HOUSE 25 C
SAINT GEORGE 378 DEPARTMENT 808 HOUSE 3 C BLA BLA BLA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);