# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)house\s+(\d+[-\s]?[a-zA-Z]?)\b"
test_str = ("FLOWERS 527 OFFICE 1217 HOUSE 1\n"
"ONE WAY 614 HOUSE 4-C\n"
"OTHER WAY 371 DEPARTMENT 209 HOUSE 25 C\n"
"SAINT GEORGE 378 DEPARTMENT 808 HOUSE 3 C BLA BLA BLA")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.