const regex = /(?i)house\s+(\d+[-\s]?[a-zA-Z]?)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)house\\s+(\\d+[-\\s]?[a-zA-Z]?)\\b', 'g')
const str = `FLOWERS 527 OFFICE 1217 HOUSE 1
ONE WAY 614 HOUSE 4-C
OTHER WAY 371 DEPARTMENT 209 HOUSE 25 C
SAINT GEORGE 378 DEPARTMENT 808 HOUSE 3 C BLA BLA BLA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}