#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]|[1-7][0-9]|80)[+^]?$"
Local $sString = "0+" & @CRLF & _
"1+" & @CRLF & _
"9+" & @CRLF & _
"10+" & @CRLF & _
"00+" & @CRLF & _
"79+" & @CRLF & _
"61^" & @CRLF & _
"" & @CRLF & _
"80" & @CRLF & _
"1" & @CRLF & _
"0" & @CRLF & _
"00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")