$re = '/^(?:[1-9]|[1-7][0-9]|80)[+^]?$/m';
$str = '0+
1+
9+
10+
00+
79+
61^
80
1
0
00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);