import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[1-9]|[1-7][0-9]|80)[+^]?$";
final String string = "0+\n"
+ "1+\n"
+ "9+\n"
+ "10+\n"
+ "00+\n"
+ "79+\n"
+ "61^\n\n"
+ "80\n"
+ "1\n"
+ "0\n"
+ "00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}