const regex = /^(?:[1-9]|[1-7][0-9]|80)[+^]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[1-9]|[1-7][0-9]|80)[+^]?$', 'gm')
const str = `0+
1+
9+
10+
00+
79+
61^
80
1
0
00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}