// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[1-9]|[1-7][0-9]|80)[+^]?$").unwrap();
let string = "0+
1+
9+
10+
00+
79+
61^
80
1
0
00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}