package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-9]|[1-7][0-9]|80)[+^]?$`)
var str = `0+
1+
9+
10+
00+
79+
61^
80
1
0
00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}