re = /^(?:[1-9]|[1-7][0-9]|80)[+^]?$/m
str = '0+
1+
9+
10+
00+
79+
61^
80
1
0
00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end