#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\?package\=greatpackage((\?|\/)(.*?))?\/success(\/|\b)"
Local $sString = "www.website.com/become-client/?package=greatpackageultra?type=business/success" & @CRLF & _
"www.website.com/become-client/?package=greatpackage?type=business/success" & @CRLF & _
"www.website.com/become-client/?package=greatpackage/success" & @CRLF & _
"www.website.com/become-client/?package=greatpackage?type=business/success" & @CRLF & _
"www.website.com/become-client/?package=greatpackage?type=business?other=nada/success" & @CRLF & _
"www.website.com/become-client/?package=greatpackage?type=business/successful" & @CRLF & _
"www.website.com/become-client/?package=greatpackagea?type=business/success" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")