$re = '/\?package\=greatpackage((\?|\/)(.*?))?\/success(\/|\b)/';
$str = 'www.website.com/become-client/?package=greatpackageultra?type=business/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage?type=business?other=nada/success
www.website.com/become-client/?package=greatpackage?type=business/successful
www.website.com/become-client/?package=greatpackagea?type=business/success
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);