using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?package\=greatpackage((\?|\/)(.*?))?\/success(\/|\b)";
string input = @"www.website.com/become-client/?package=greatpackageultra?type=business/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage?type=business?other=nada/success
www.website.com/become-client/?package=greatpackage?type=business/successful
www.website.com/become-client/?package=greatpackagea?type=business/success
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}