import Foundation
let pattern = #"\?package\=greatpackage((\?|\/)(.*?))?\/success(\/|\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
www.website.com/become-client/?package=greatpackageultra?type=business/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage?type=business?other=nada/success
www.website.com/become-client/?package=greatpackage?type=business/successful
www.website.com/become-client/?package=greatpackagea?type=business/success
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)