import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\?package\\=greatpackage((\\?|\\/)(.*?))?\\/success(\\/|\\b)";
final String string = "www.website.com/become-client/?package=greatpackageultra?type=business/success\n"
+ "www.website.com/become-client/?package=greatpackage?type=business/success\n"
+ "www.website.com/become-client/?package=greatpackage/success\n"
+ "www.website.com/become-client/?package=greatpackage?type=business/success\n"
+ "www.website.com/become-client/?package=greatpackage?type=business?other=nada/success\n"
+ "www.website.com/become-client/?package=greatpackage?type=business/successful\n"
+ "www.website.com/become-client/?package=greatpackagea?type=business/success\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}