package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\?package\=greatpackage((\?|\/)(.*?))?\/success(\/|\b)`)
var str = `www.website.com/become-client/?package=greatpackageultra?type=business/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage?type=business?other=nada/success
www.website.com/become-client/?package=greatpackage?type=business/successful
www.website.com/become-client/?package=greatpackagea?type=business/success
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}