// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\?package\=greatpackage((\?|\/)(.*?))?\/success(\/|\b)").unwrap();
let string = "www.website.com/become-client/?package=greatpackageultra?type=business/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage/success
www.website.com/become-client/?package=greatpackage?type=business/success
www.website.com/become-client/?package=greatpackage?type=business?other=nada/success
www.website.com/become-client/?package=greatpackage?type=business/successful
www.website.com/become-client/?package=greatpackagea?type=business/success
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}