#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:1?\d(?:\.\d\d?)?|20)$"
Local $sString = "19.33" & @CRLF & _
"0.2" & @CRLF & _
"0.91" & @CRLF & _
"0" & @CRLF & _
"2.4" & @CRLF & _
"15.88" & @CRLF & _
"20" & @CRLF & _
"0" & @CRLF & _
"0.5" & @CRLF & _
"0.91" & @CRLF & _
"1" & @CRLF & _
"20.1" & @CRLF & _
"21" & @CRLF & _
"22" & @CRLF & _
"23" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")