$re = '/^(?:1?\d(?:\.\d\d?)?|20)$/m';
$str = '19.33
0.2
0.91
0
2.4
15.88
20
0
0.5
0.91
1
20.1
21
22
23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);