import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:1?\\d(?:\\.\\d\\d?)?|20)$";
final String string = "19.33\n"
+ "0.2\n"
+ "0.91\n"
+ "0\n"
+ "2.4\n"
+ "15.88\n"
+ "20\n"
+ "0\n"
+ "0.5\n"
+ "0.91\n"
+ "1\n"
+ "20.1\n"
+ "21\n"
+ "22\n"
+ "23\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}