use strict;
my $str = '19.33
0.2
0.91
0
2.4
15.88
20
0
0.5
0.91
1
20.1
21
22
23
';
my $regex = qr/^(?:1?\d(?:\.\d\d?)?|20)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}