# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[color=(.*?)\](.*?)\[\\/color\]//;t' <<< "[color=red;font-size:100pt;]DEFACED[/color]"