#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[color=(.*?)\](.*?)\[\/color\]"
Local $sString = "[color=red;font-size:100pt;]DEFACED[/color]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)