re = /\[color=(.*?)\](.*?)\[\/color\]/
str = '[color=red;font-size:100pt;]DEFACED[/color]'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result