const regex = /\[color=(.*?)\](.*?)\[\/color\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[color=(.*?)\\](.*?)\\[\\\/color\\]', '')
const str = `[color=red;font-size:100pt;]DEFACED[/color]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);