use strict;
my $str = '[color=red;font-size:100pt;]DEFACED[/color]';
my $regex = qr/\[color=(.*?)\](.*?)\[\/color\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";