$re = '/\[color=(.*?)\](.*?)\[\/color\]/';
$str = '[color=red;font-size:100pt;]DEFACED[/color]';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;