using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+[-* ](\w+)[-* ]\d{4}-\d{2}-\d{2}";
string input = @"3*Canada-2022-06-04
144 Brazil*1998-11-26
18_USA-2009-05-16";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}