const regex = /\d+[-* ](\w+)[-* ]\d{4}-\d{2}-\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+[-* ](\\w+)[-* ]\\d{4}-\\d{2}-\\d{2}', 'gm')
const str = `3*Canada-2022-06-04
144 Brazil*1998-11-26
18_USA-2009-05-16`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}