use strict;
my $str = '3*Canada-2022-06-04
144 Brazil*1998-11-26
18_USA-2009-05-16';
my $regex = qr/\d+[-* ](\w+)[-* ]\d{4}-\d{2}-\d{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}