import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+[-* ](\\w+)[-* ]\\d{4}-\\d{2}-\\d{2}";
final String string = "3*Canada-2022-06-04\n"
+ "144 Brazil*1998-11-26\n"
+ "18_USA-2009-05-16";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}