re = /\d+[-* ](\w+)[-* ]\d{4}-\d{2}-\d{2}/m
str = '3*Canada-2022-06-04
144 Brazil*1998-11-26
18_USA-2009-05-16'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end