$re = '/\d+[-* ](\w+)[-* ]\d{4}-\d{2}-\d{2}/m';
$str = '3*Canada-2022-06-04
144 Brazil*1998-11-26
18_USA-2009-05-16';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);