using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""a[^""]*z""\s*:";
string substitution = @"""alpha"":";
string input = @"{{ ""a"" : { ""b"" : 4 }, ""b"" : { ""c"" : { ""d"" : ""e"", ""awefz"" : { ""l"" : ""c"" } } }, ""c"" : { ""abcz"" : ""here"" } }";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}