const regex = /"a[^"]*z"\s*:/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"a[^"]*z"\\s*:', 'ig')
const str = `{{ "a" : { "b" : 4 }, "b" : { "c" : { "d" : "e", "awefz" : { "l" : "c" } } }, "c" : { "abcz" : "here" } }`;
const subst = `"alpha":`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);