re = /"a[^"]*z"\s*:/i
str = '{{ "a" : { "b" : 4 }, "b" : { "c" : { "d" : "e", "awefz" : { "l" : "c" } } }, "c" : { "abcz" : "here" } }'
subst = '"alpha":'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result