use strict;
my $str = '{{ "a" : { "b" : 4 }, "b" : { "c" : { "d" : "e", "awefz" : { "l" : "c" } } }, "c" : { "abcz" : "here" } }';
my $regex = qr/"a[^"]*z"\s*:/ip;
my $subst = '"alpha":';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";