import re
regex = re.compile(r"\"a[^\"]*z\"\s*:", flags=re.IGNORECASE)
test_str = "{{ \"a\" : { \"b\" : 4 }, \"b\" : { \"c\" : { \"d\" : \"e\", \"awefz\" : { \"l\" : \"c\" } } }, \"c\" : { \"abcz\" : \"here\" } }"
subst = "\"alpha\":"
result = regex.sub(subst, test_str)
if result:
print(result)