import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"a[^\"]*z\"\\s*:";
final String string = "{{ \"a\" : { \"b\" : 4 }, \"b\" : { \"c\" : { \"d\" : \"e\", \"awefz\" : { \"l\" : \"c\" } } }, \"c\" : { \"abcz\" : \"here\" } }";
final String subst = "\"alpha\":";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}