import Foundation
let pattern = #""a[^"]*z"\s*:"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"{{ "a" : { "b" : 4 }, "b" : { "c" : { "d" : "e", "awefz" : { "l" : "c" } } }, "c" : { "abcz" : "here" } }"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""alpha":"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)