#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) *\"[^\"]+\" *|[^\r\n\"]+"
Local $sString = ""Content1 " & @CRLF & _
" block" " & @CRLF & _
" Contentn2 " & @CRLF & _
" New conenet " " & @CRLF & _
" Conetent 3"" & @CRLF & _
"" & @CRLF & _
""Content1 \r\n block" \r\n Contentn2 \r\n New conenet " \r\n Conetent 3""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")